Blog

Report
The Samson C01U Mic -- Audio Fix?
August 4, 2009 | 2:55 am

Short story: Get the SoftPre uninstaller and run it. Longer story -- click through...

I've had my Samson C01U USB studio condenser microphone for quite some time. Love the thing to death, but I always had to open its SoftPre preamp software AND the sound system preference panel to get decent input. I had to leave those open while running Garageband or other recording software, or the thing just didn't get a good take.

Others on iCompositions seemed to have similar issues or none at all -- there didn't seem to be a pattern. However, I may have found something that could be helpful to anyone testing and playing and trying to wring out every possible bit they can from what really is a very good low-cost condenser mic.

My new Mac Mini came with Mac OS X 10.5 and the latest Garageband software installed. After using Migration Assistant to move my old stuff to it, Samson's SoftPre software was there as well. However, it didn't run, because Samson hasn't upgraded it and does not plan to. Using the sound preference panel was an iffy thing -- seemed to work, then not. The new Garageband has audio input level control, and that seemed to help some, but I just couldn't get up to the levels I got previously with SoftPre on my old PowerPC Mini running Mac OS 10.4.

My next clue: a friend told me during audio chat that the audio was very low and sounded awful. It was then that I checked for a new version of SoftPre, discovered there was none, and noticed Samson had a special uninstaller for SoftPre. Could SoftPre be causing issues even though it couldn't run and wasn't compatible with 10.5?

I downloaded the uninstaller and ran it. Afterward, the audio input level increased incredibly. Recording into Garageband is now better than it was before! I don't have to crank up the level input slider nearly as much as I did on the old Mini, and that means I can use less compression -- now more for effect than for sheer volume/level.

So, if you can't seem to get the level of volume on your input from your Samson USB mic, and especially if you're using Mac OS X 10.5 and Garageband 5.x (from iLife '09) and somehow have that SoftPre on your system, go grab Samson's uninstaller and run the thing. Here's the link to it:

http://www.samsontech.com/main/misc.cfm?pageID=45

Hopefully that'll do the trick! Happy recording!

Comments

Moderator

becwil's artist icon
Quote Report
Wow! Who would have thought that uninstalling something that you weren't using would help. Nice!
Latest Song: Go For Broke (RR)
Artist Page Send Message August 4, 2009 | 1:43 pm
Moderator

offbalance's artist icon
Quote Report
Exactly!

Now, I just have to figure out some more tweaks on it. It does sound different, but I'm sure that's due to how my sound preference panel and the Garageband level settings are interacting. At least, I think so. Once I get the right settings, I should get back to a more warm sound. I hope.

Of course, this may all be moot when I get the audio interface I want... but that could be quite a way down the road. smiley
Latest Song: The Dice Guys Theme
Artist Page Send Message August 5, 2009 | 12:23 am

Post a Comment


Please login or register to post a comment.

Advertisement