Forums » Site Support » Album Page not loading.

Artist

Reply with quoteReport
When I try using a CDBaby link, it just goes to a blank white screen.
When I put in an iTunes link, it gets stuck at about ⅛ loading.
Artist Page Send Message Apr 13, 2018 | 11:29 am
Artist

Reply with quoteReport
Sorry to hear you also seem to be having problems -( Stringidae
Thats what keeps happening to me too.
I kept getting site not secure and my virus checker kept blocking an image that tried to keep downloading...

Some song pages i tried to load just went blank same as you've described.

I shared a link from my page Dancing in Space remix. on my face book page. And Sorry THAU its got your Avitar on it instead of my own however the link goes to my own page here on icomps. Can anyone help please. Thanks
Latest Song: Ambient On Sunday
Artist Page Send Message Apr 13, 2018 | 2:19 pm
Moderator

Reply with quoteReport
Ruby pasting eido's response to Strigidae from chat to here:

eido: Strigidae: Your album's 'Buy Now' link points to a broken URL. The URL you have is https//itunes.apple.com/us/album/agenbite-of-inwyt/1216480363 . - it's missing a colon between the https and the slashes

eido: i.e. it should start https:/ rather than https/

eido: I've never made an album on this site so I'm not sure if you supply the URL yourself or not, but if you did, that's likely to be the source of your problem.
eido: hth
Latest Song: I'll Shoot The Moon
Artist Page Send Message Apr 13, 2018 | 3:23 pm
Artist

Reply with quoteReport
I'm not sure how that happened as I just copy and pasted. So I did it again and checked. This time I got the blank why screen like with the CDBaby attempt.
Artist Page Send Message Apr 13, 2018 | 3:54 pm
Artist

Reply with quoteReport
Just noticed it was loading, but not loading photo and link correctly. Figured out the link issue. It was adding an extra Http:// after submitting. I still don't know how to fix the picture issue.
Artist Page Send Message Apr 13, 2018 | 4:21 pm
Moderator

Reply with quoteReport
@Strigidae: What size is the image you’re using for the album art? I’ve found that iComp tends to want art to be under a certain size, otherwise it won’t accept the picture (presumably this is to stop people uploading massive images and using tons of storage space). Try making your image smaller and seeing if that works - eg try 300x300 pixels. (I don’t know offhand what the limit is and you may well be able to go larger than that but 300x300 should be small enough to confirm if that’s the issue.)
Artist Page Send Message Apr 14, 2018 | 3:49 am
Artist

Reply with quoteReport
I've tried different sizes. It does say 300 pixels. I'm not that worried about the picture, at least the album is posted now. Thanks.
Artist Page Send Message Apr 15, 2018 | 10:21 pm
Artist

Reply with quoteReport
Just realised the problem is when logging into icompositions the loading page is fine//// no warning
I can also use the search box thats ok/
Problem
. IS when I start to type in my user name even the first letter brings the red warning.. Website not secure
Ive changed my password/ still does it.
Latest Song: Ambient On Sunday
Artist Page Send Message Apr 16, 2018 | 5:00 pm
Advertisement